Engine noise on the radio only when OD is disengaged

Discussions about MX5 Alarms, Car Stereos, Lighting, Batteries or other Electrical related issues

Moderators: Growler, jif, SLYDIT, brownie

Post Reply
MrGrey
I have stars, you haven't. Deal with it
I have stars, you haven't.  Deal with it
Posts: 1172
Joined: Mon Jan 21, 2013 3:52 am
Location: Northland

Engine noise on the radio only when OD is disengaged

Post by MrGrey » Thu Jan 24, 2013 3:11 pm

hello, I have an odd problem which I was hoping some of you guys may have some insight into the possible causes.

my na mx5 has an aftermarket headunit (an automedia am3100bt running 2x 6.5" JVC's in the doors and 4x 4" JVC's in the headrests)

the problem i have is the whiney engine noise commonly found with a bad earth but it appears only when i have overdrive disengaged (when I am commuting around town)

next week I will have a sparky installing a boot release and wiring up an underseat sub and would love to be able to point out possible causes of this whine (even though he will most likely install a suppressor)

thanks in advance for any light you may shed on the matter :)

na6*dori
Need, more, 5-ing, time....
Need, more, 5-ing, time....
Posts: 115
Joined: Wed Jul 25, 2012 8:01 pm
Location: Nelson

Post by na6*dori » Thu Jan 24, 2013 5:38 pm

have you tried a better earth?
In which i trust, a cable ties a must

SLYDIT
Keep calm, Forum Moderator here.
Keep calm, Forum Moderator here.
Posts: 1607
Joined: Sun May 21, 2006 6:18 pm
Location: In the Garage.

Post by SLYDIT » Thu Jan 24, 2013 8:40 pm

na6*dori wrote:have you tried a better earth?
+1 there is an earth just in front of the diff on the PPF frame and the earths under the wiper motor. get all of them removed and cleaned along with the one on the engine block.
RED '90 TURBO.
SCARING PRIUS DRIVERS SINCE 2002

Post Reply

Return to “MX5 Electrical, Audio, Alarms & Electronics”

Who is online

Users browsing this forum: No registered users and 1 guest